summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 21:43:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:36 -0400
commit4f9913513165e8e1c5615686db2f7724d941126a (patch)
tree17b9c359fcf902371b4c0c37ece28580c80a3518
parente50781c1a35d14dce5b1b61ef5639bc8bd7d347b (diff)
gnu: gnome-terminal: Update to 3.44.1.
* gnu/packages/gnome.scm (gnome-terminal): Update to 3.44.1. [build-system]: Use meson-build-system. [configure-flags]: Remove argument. [glib-or-gtk?]: New argument. [phases]{patch-/bin/true}: Delete phase. {patch-build-system}: New phase. [native-inputs]: Delete labels and sort. Replace intltool with gettext-minimal. Add python. [inputs]: Sort. Add gnome-shell and nautilus.
-rw-r--r--gnu/packages/gnome.scm55
1 files changed, 33 insertions, 22 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4509d4e15b..cc8faf7159 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5314,7 +5314,7 @@ more fun.")
(define-public gnome-terminal
(package
(name "gnome-terminal")
- (version "3.40.3")
+ (version "3.44.1")
(source
(origin
(method url-fetch)
@@ -5323,35 +5323,46 @@ more fun.")
name "-" version ".tar.xz"))
(sha256
(base32
- "08hsic7sn32xw12i3j0ard2bhfhp8gmzqm0pa8xzl5l1jhzsmsfb"))))
- (build-system glib-or-gtk-build-system)
+ "0yykb64yi1h0g65q890jf5awjr2sdvfda4xbxnmajcgj3zp20vzv"))))
+ (build-system meson-build-system)
(arguments
- '(#:configure-flags
- (list "--disable-migration" "--disable-search-provider"
- "--without-nautilus-extension")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-/bin/true
- (lambda _
- (substitute* "configure"
- (("/bin/true") (which "true"))))))))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-build-system
+ ;; The build system looks for a dbus file from gnome-shell in the
+ ;; installation tree of teh package it is configuring...
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/meson.build"
+ (("gt_prefix.*'org.gnome.ShellSearchProvider2.xml'")
+ (format #f "'~a'" (search-input-file
+ inputs "share/dbus-1/interfaces/\
+org.gnome.ShellSearchProvider2.xml"))))))
+ (add-before 'install 'disable-gtk-update-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/"))))))
(native-inputs
- `(("docbook-xsl" ,docbook-xsl)
- ("pkg-config" ,pkg-config)
- ("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("libxslt" ,libxslt)
- ("xmllint" ,libxml2)))
+ (list desktop-file-utils
+ docbook-xsl
+ gettext-minimal
+ `(,glib "bin")
+ itstool
+ libxml2
+ libxslt
+ pkg-config
+ python))
(propagated-inputs
(list dconf))
(inputs
- (list gtk+
- vte
+ (list gnome-shell
gnutls
gsettings-desktop-schemas
+ gtk+
+ nautilus ;for extension
`(,util-linux "lib")
- vala))
+ vala
+ vte))
(home-page "https://wiki.gnome.org/Apps/Terminal")
(synopsis "Terminal emulator")
(description