summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-01 19:21:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-01 19:21:37 +0100
commit510c2206e4faabee1978c4194745183707bb943e (patch)
tree360663452d1183dadeba5307da068e28bc566deb
parentff586211aaf0e3b468ff3cedc5ede18e8ab529dd (diff)
gnu: Add r-job.
* gnu/packages/cran.scm (r-job): New variable. Change-Id: I37a0870bd22d5bc2e700f843fca49f242a197440
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 36c00d2885..bf9e94adee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4201,6 +4201,29 @@ performance evaluation of BSS algorithms, are given. The package is described
in Miettinen, Nordhausen and Taskinen (2017) <doi:10.18637/jss.v076.i02>.")
(license license:gpl2+)))
+(define-public r-job
+ (package
+ (name "r-job")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "job" version))
+ (sha256
+ (base32 "0d7pw3q5lqlgmav1vx63y8l6gdav96656bg378wj001rx5gx052h"))))
+ (properties `((upstream-name . "job")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-digest r-rstudioapi))
+ (home-page "https://cran.r-project.org/package=job")
+ (synopsis "Run code as an RStudio job")
+ (description
+ "Call @code{job::job({<code here>})} to run R code as an RStudio job and
+keep your console free in the meantime. This allows for a productive workflow
+while testing (multiple) long-running chunks of code. It can also be used to
+organize results using the RStudio Jobs GUI or to test code in a clean
+environment. Two RStudio Addins can be used to run selected code as a job.")
+ (license license:expat)))
+
(define-public r-jsonify
(package
(name "r-jsonify")