summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-07-28 23:38:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-01 23:53:23 +0200
commit5baa37b56cbde873b8dedca343dd9c8d8c080528 (patch)
treecfc35263e664531deb5ef3a1e6bceba8c0f7ae69
parent1085514a1899f24e8a17f46c186e55169337272d (diff)
gnu: Add r-phyclust.
* gnu/packages/cran.scm (r-phyclust): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a677360700..fc7fd0467e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11699,6 +11699,31 @@ supplied Jacobian, for specifying a banded numerical Jacobian and for allowing a
singular or ill-conditioned Jacobian.")
(license license:gpl2+)))
+(define-public r-phyclust
+ (package
+ (name "r-phyclust")
+ (version "0.1-30")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "phyclust" version))
+ (sha256
+ (base32
+ "0fy9q95vmlm9idpax7alhpfwn30gflnc9md72g91jypyxkx5nr7p"))))
+ (properties `((upstream-name . "phyclust")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape))
+ (home-page "https://snoweye.github.io/phyclust/")
+ (synopsis "Studying phyloclustering and exploring DNA sequence data")
+ (description
+ "@dfn{Phylogenetic clustering} (phyloclustering) is an evolutionary continuous
+time Markov Chain model-based approach to identify population structure from
+molecular data without assuming linkage equilibrium. The package @code{phyclust}
+provides a convenient implementation of phyloclustering for DNA and SNP data,
+capable of clustering individuals into subpopulations and identifying molecular
+sequences representative of those subpopulations. It is designed in @code{C} for
+performance and interfaced with @code{R} for visualization.")
+ (license license:gpl2+)))
+
(define-public r-physicalactivity
(package
(name "r-physicalactivity")