summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:32:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:42:52 +0200
commit5c2d76397d25f7defa5982a769c50dac1b9604b8 (patch)
tree0788c91d99c27db7b1875853bcc91c1bc481927e
parent0c1408bef3cf3fa3413f8a6c5ed8430456d53359 (diff)
gnu: Add texlive-texnegar.
* gnu/packages/tex.scm (texlive-texnegar): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 64c7dd4e37..8f8f6b5139 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -20560,6 +20560,28 @@ no file is specified), filters out less relevant messages, and displays
a summary report.")
(license license:gpl3+)))
+(define-public texlive-texnegar
+ (package
+ (name "texlive-texnegar")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/texnegar/"
+ "source/latex/texnegar/"
+ "tex/latex/texnegar/")
+ (base32
+ "0rza5bmn7cm85aznnffpmfv6b8776jxkpfwhs0y04f83sdjapw63")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/texnegar")
+ (synopsis "Kashida justification in XeLaTeX and LuaLaTeX")
+ (description
+ "In some cursive scripts such as Persian or Arabic, kashida is used to
+create justification. In this type of justification characters are elongated
+rather than expanding spaces between words. This package extends the kashida
+justification to be used with the LuaTeX engine.")
+ (license license:lppl1.3c)))
+
(define-public texlive-texosquery
(package
(name "texlive-texosquery")