summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-11-28 13:36:41 +0400
committerAndrew Tropin <andrew@trop.in>2022-11-28 13:36:41 +0400
commit622c3be7b6b82faf587fc5cfdb1c921ae52fc6c7 (patch)
treed011001a5446f766247766f3026443229785fa39
parent7922f610d28ef28b47370ae998cc149d3da165f9 (diff)
Revert "gnu: Add rust-swayipc-3."
This reverts commit 655956131c4208feea3167eac992e8cf204be0d3.
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 7 insertions, 26 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e07a8d0cda..97a1fd9b82 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55725,24 +55725,25 @@ values without proliferating generics.")
(description "This package provides custom derive for @code{sval}.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-swayipc-3
+(define-public rust-swayipc-2
(package
(name "rust-swayipc")
- (version "3.0.1")
+ (version "2.7.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "swayipc" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "16pf4r6svf99p73b8dhdannkvhfvmbjb4rx7gifxh8xj53rwy7db"))))
+ (base32 "03r15c2sijyrxmpsyjgma4gz7zmdl1g8akjnjkw6hrml91d5dilj"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
+ `(#:tests? #f ; test sync::tests::connect ... FAILED
#:cargo-inputs
(("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-swayipc-types" ,rust-swayipc-types-1))))
+ ("rust-async-std" ,rust-async-std-1)
+ ("rust-swayipc-command-builder" ,rust-swayipc-command-builder-0.1)
+ ("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://github.com/jaycefayne/swayipc-rs")
(synopsis "Library for controlling sway through its IPC interface")
(description
@@ -55750,26 +55751,6 @@ values without proliferating generics.")
interface.")
(license license:expat)))
-(define-public rust-swayipc-2
- (package
- (inherit rust-swayipc-3)
- (name "rust-swayipc")
- (version "2.7.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "swayipc" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "03r15c2sijyrxmpsyjgma4gz7zmdl1g8akjnjkw6hrml91d5dilj"))))
- (arguments
- `(#:tests? #f ; test sync::tests::connect ... FAILED
- #:cargo-inputs
- (("rust-serde" ,rust-serde-1)
- ("rust-async-std" ,rust-async-std-1)
- ("rust-swayipc-command-builder" ,rust-swayipc-command-builder-0.1)
- ("rust-serde-json" ,rust-serde-json-1))))))
-
(define-public rust-swayipc-command-builder-0.1
(package
(name "rust-swayipc-command-builder")