summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-08 01:45:30 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:23 -0400
commit6414c5a139c57b9bdde12e51e36b40050eb77e45 (patch)
tree50a4a763b64d0d5e1a57c2675ed6f8faea37abc2
parentd030239c655ec43f289ef58b7af674fb05e3880a (diff)
gnu: Add ruby-concurrent-ruby.
* gnu/packages/ruby.scm (ruby-concurrent-ruby): New variable.
-rw-r--r--gnu/packages/ruby.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7ac94b6578..2d40609d7d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10474,6 +10474,44 @@ patterns.")
(home-page "http://www.concurrent-ruby.com")
(license license:expat)))
+(define-public ruby-concurrent-ruby
+ (package
+ (name "ruby-concurrent-ruby")
+ (version "1.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference ;for tests
+ (url "https://github.com/ruby-concurrency/concurrent-ruby")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vz4rl0nplq14dk9nx45g59i1sk2h53w1mjlrdiyjf780q4a1i38"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:tests? #f ;the test suite is run in ruby-concurrent-ruby-edge
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'delete-unwanted-gemspecs
+ (lambda _
+ (for-each delete-file
+ '("concurrent-ruby-ext.gemspec"
+ "concurrent-ruby-edge.gemspec"))))
+ (add-after 'unpack 'do-not-install-concurrent_ruby.jar
+ (lambda _
+ ;; This file is only built when building the Java
+ ;; extension.
+ (substitute* "concurrent-ruby.gemspec"
+ (("'lib/concurrent-ruby/concurrent/concurrent_ruby.jar'")
+ "")))))))
+ (synopsis "Concurrency library for Ruby")
+ (description "Concurrent Ruby includes concurrency tools such as agents,
+futures, promises, thread pools, actors, supervisors, and more. It is
+inspired by Erlang, Clojure, Go, JavaScript, actors, and classic concurrency
+patterns.")
+ (home-page "https://github.com/ruby-concurrency/concurrent-ruby")
+ (license license:expat)))
+
(define-public ruby-pkg-config
(package
(name "ruby-pkg-config")