summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-18 18:57:24 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-21 09:55:01 +0200
commit6b915fe58b452a785ee98529d26d1a576444378a (patch)
tree99e7b970f11ca902c8187af03b73f57bbaf2138b
parent9365d0e16b76b8ab703be1cdd8c244b41b4d2dd4 (diff)
gnu: Add emacs-org-cliplink.
* gnu/packages/emacs-xyz.scm (emacs-org-cliplink): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c126eadee..0acede2da4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33502,6 +33502,47 @@ tree to go back to previous buffer states. To use vundo, type @kbd{M-x vundo RE
the buffer you want to undo. An undo tree buffer should pop up.")
(license license:gpl3+)))
+(define-public emacs-org-cliplink
+ (let ((commit "13e0940b65d22bec34e2de4bc8cba1412a7abfbc")
+ (revision "0"))
+ (package
+ (name "emacs-org-cliplink")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/rexim/org-cliplink")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1avyiw8vlv4n1r7zqvc6wjlsz7jl2pqaprzpm782gzp0c999pssl"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "ert-runner")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-geiser-racket-binary
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "org-cliplink-transport.el"
+ (("curl\")")
+ (string-append (search-input-file inputs "bin/curl")
+ "\")"))))))))
+ (native-inputs
+ (list emacs-el-mock emacs-ert-runner emacs-undercover))
+ (inputs
+ (list curl))
+ (home-page "https://github.com/rexim/org-cliplink/")
+ (synopsis "Insert Org mode links from the clipboard")
+ (description
+ "Org Cliplink provides a simple command that takes a URL from the
+clipboard and inserts an Org mode link with a title of a page found by the URL
+into the current buffer.")
+ (license license:expat))))
+
(define-public emacs-project-x
;; There is no proper release.
;; The base version is extracted from the README.org.