summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-26 19:13:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-27 08:01:19 +0200
commit6c02d516b5715ca12bffdad379786ee1d81f613b (patch)
tree83589418f7d343c3ed081c65294d2a4f4d3f8b90
parent3778f778c37110460dd78088200cbd05eb0c49e4 (diff)
gnu: go-github-com-google-go-cmp-cmp: Skip tests with gccgo.
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp)[arguments]: Override check phase to skip it when building with gccgo. Change-Id: Ie2b5005648882c5a65ed484e5d203f1076dcb768
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ead9622d8c..7a9e081b4c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8324,7 +8324,15 @@ colorized or SGR defined output to the standard output.")
(build-system go-build-system)
(arguments
'(#:import-path "github.com/google/go-cmp/cmp"
- #:unpack-path "github.com/google/go-cmp"))
+ #:unpack-path "github.com/google/go-cmp"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(synopsis "Determine equality of values in Go")
(description
"This package is intended to be a more powerful and safer