summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-07 12:13:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 12:13:01 +0300
commit6f19d7001bd6a10aed5e9371c30e383f8badf6e5 (patch)
tree9e99466042f6b6dd72b7878b6a39c4fe44b346c7
parent2a38bc9a7787454251f6d90ea55f228aa7bc01f0 (diff)
gnu: python-blessed: Run test suite.
* gnu/packages/python-xyz.scm (python-blessed)[arguments]: Run the test suite.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f50fafb510..a5c99a6f20 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27821,6 +27821,16 @@ placement and scaling of SVG figures and adding markers, such as labels.")
;; Don't get hung up on Windows test failures.
(delete-file "blessed/win_terminal.py")))))
(build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (delete-file "tox.ini")
+ (invoke "python" "-m" "pytest" "tests")))))))
(propagated-inputs
(list python-jinxed python-six python-wcwidth))
(native-inputs