summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 16:42:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:37 +0100
commit72e5c6e95f1b16b08a8d69680833f7ce15b8e50f (patch)
treec4664221f7ece41dffe0ff268db54163cad4f7f6
parent647ff4a98b422028c162fb4f861ad9d323a4cadf (diff)
gnu: Add r-rglpk.
* gnu/packages/cran.scm (r-rglpk): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b7555f959c..d6891ce6c3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16275,3 +16275,29 @@ damage (load duration) models based on failure time data under a Bayesian
framework, using @dfn{Approximate Bayesian Computation} (ABC), and to assess
long-term reliability under stochastic load profiles.")
(license license:gpl3)))
+
+(define-public r-rglpk
+ (package
+ (name "r-rglpk")
+ (version "0.6-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Rglpk" version))
+ (sha256
+ (base32
+ "19mzpyimzq9zqnbi05j79b2di3nzaln8swggs9p8sqdr60qvr3d2"))))
+ (properties `((upstream-name . "Rglpk")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-slam" ,r-slam)))
+ (inputs
+ `(("glpk" ,glpk)))
+ (home-page "http://R-Forge.R-project.org/projects/rglp/")
+ (synopsis "R interface to the GNU Linear Programming Kit")
+ (description
+ "This package provides an R interface to the GNU Linear Programming Kit,
+software for solving large-scale @dfn{linear programming} (LP), @dfn{mixed
+integer linear programming} (MILP) and other related problems.")
+ ;; Either license
+ (license (list license:gpl2 license:gpl3))))