summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 22:04:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:11 +0200
commit7881695e1bad2552716bbb666bdac2688065a56f (patch)
tree5db8b4044f8799e17e17558a8d382ab2135cefdc
parent046971c319b31ef1d16aae1cf97d336d322bc7cb (diff)
gnu: texlive-lualibs: Refresh package definition.
* gnu/packages/tex.scm (texlive-lualibs): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 569f43153a..77b8afcb0c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4534,24 +4534,22 @@ they are not directly related to Unicode mathematics typesetting.")
(define-public texlive-lualibs
(package
- (inherit
- (simple-texlive-package
- "texlive-lualibs"
- (list "doc/luatex/lualibs/"
- "source/luatex/lualibs/"
- "tex/luatex/lualibs/")
- (base32 "0gf60vj9y75a7dlrmpbyqgsa00s1717r6if3lm5ldm41i9fm8ywz")
- ;; The source dtx file only unpacks three files. This is why we
- ;; install all the files as they are, because there is no clear
- ;; way to generate them all.
- #:trivial? #true))
- (home-page "https://ctan.org/macros/luatex/generic/lualibs")
+ (name "texlive-lualibs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/lualibs/" "source/luatex/lualibs/"
+ "tex/luatex/lualibs/")
+ (base32
+ "0gf60vj9y75a7dlrmpbyqgsa00s1717r6if3lm5ldm41i9fm8ywz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lualibs")
(synopsis "Additional Lua functions for LuaTeX macro programmers")
(description
"Lualibs is a collection of Lua modules useful for general programming.
-The bundle is based on Lua modules shipped with ConTeXt, and made available in
+The bundle is based on lua modules shipped with ConTeXt, and made available in
this bundle for use independent of ConTeXt.")
- ;; GPL version 2 only
(license license:gpl2)))
(define-deprecated-package texlive-luatex-lualibs texlive-lualibs)