summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:59:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:14 +0200
commit7ca7453f689cb34a744c2e04df67028dd4306fdc (patch)
tree7b0259ad2bd61fe8c0851c054658ecec31b87ea2
parente28d5c9e8c791a2649e11674eb5fc0d93d2aed96 (diff)
gnu: Add texlive-xpicture.
* gnu/packages/tex.scm (texlive-xpicture): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 031945dde1..795851d91f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5764,6 +5764,27 @@ a Cistercian numeral, and @code{\\cisterciannum@{<integer>@}}, formats the
integer (given as a string) as a Cistercian numeral.")
(license license:lppl1.3c)))
+(define-public texlive-xpicture
+ (package
+ (name "texlive-xpicture")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xpicture/"
+ "source/latex/xpicture/"
+ "tex/latex/xpicture/")
+ (base32
+ "0pzqnrk7mw1k9madah2ym9qsy20d8i1x1abkvkxvx7rxw7w38s2p")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xpicture")
+ (synopsis "Extensions of LaTeX picture drawing")
+ (description
+ "The package extends the facilities of the @code{pict2e} and the
+@code{curve2e} packages, providing extra reference frames, conic section
+curves, graphs of elementary functions and other parametric curves.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")