summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-09 13:17:18 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:57 +0200
commit7d21f5b1b65fb1309ece1bd842e0d95de895ecff (patch)
tree4e2941cd904ad2677de06f3e65879b72d5952286
parent9ad392fc7fbaf1cbb9025c11d914d5454bf83847 (diff)
gnu: autotrace: Update to 0.31.9.
* gnu/packages/patches/autotrace-glib-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/graphics.scm (autotrace): Update to 0.31.9. [source](patches): Remove. [arguments]: Add #:phases. [native-inputs]: Add PROCPS. Remove GETTEXT-MINIMAL.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/graphics.scm82
-rw-r--r--gnu/packages/patches/autotrace-glib-compat.patch50
3 files changed, 44 insertions, 89 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index faf2e35003..60299d0cea 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -889,7 +889,6 @@ dist_patch_DATA = \
%D%/packages/patches/audiofile-hurd.patch \
%D%/packages/patches/audiofile-function-signature.patch \
%D%/packages/patches/automake-skip-amhello-tests.patch \
- %D%/packages/patches/autotrace-glib-compat.patch \
%D%/packages/patches/avahi-localstatedir.patch \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/awesome-reproducible-png.patch \
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 5b3b7b0087..3a824c18cd 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -310,47 +310,53 @@ objects!")
(license license:lgpl2.1+)))
(define-public autotrace
- (let ((commit "travis-20200219.65")
- (version-base "0.40.0"))
- (package
- (name "autotrace")
- (version (string-append version-base "-"
- (if (string-prefix? "travis-" commit)
- (string-drop commit 7)
- commit)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/autotrace/autotrace")
- (commit commit)))
- (file-name (git-file-name name version))
- (patches (search-patches "autotrace-glib-compat.patch"))
- (sha256
- (base32
- "1p9gy2vg0jzwjwz34lj95vvknnyswpc4qq63j83bh0m1gz09qh2w"))))
- (build-system gnu-build-system)
- (native-inputs
- (list which
- pkg-config
- autoconf
- automake
- intltool
- libtool
- gettext-minimal))
- (inputs
- (list glib
- libjpeg-turbo
- libpng
- imagemagick
- pstoedit))
- (home-page "https://github.com/autotrace/autotrace")
- (synopsis "Bitmap to vector graphics converter")
- (description "AutoTrace is a utility for converting bitmap into vector
+ (package
+ (name "autotrace")
+ (version "0.31.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/autotrace/autotrace")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fsg13pg72ac51l3fkzvyf7h9mzbvfxp9vfjfiwkyvx6hbm83apj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pkg-config-file
+ (lambda _
+ ;; autotrace can be built against either GraphicsMagick or
+ ;; ImageMagick. However the pkg-config file refers to
+ ;; non-existent MAGICK_ variables instead of GRAPHICSMAGICK_
+ ;; or IMAGEMAGICK_; fix that.
+ (substitute* "autotrace.pc.in"
+ (("@MAGICK_(LIBS|CFLAGS)@" _ var)
+ (string-append "@IMAGEMAGICK_" var "@"))))))))
+ (native-inputs
+ (list which
+ autoconf
+ automake
+ libtool
+ intltool
+ pkg-config
+ procps)) ;for tests
+ (inputs
+ (list glib
+ imagemagick
+ libjpeg-turbo
+ libpng
+ pstoedit))
+ (home-page "https://github.com/autotrace/autotrace")
+ (synopsis "Bitmap to vector graphics converter")
+ (description "AutoTrace is a utility for converting bitmap into vector
graphics. It can trace outlines and midlines, effect color reduction or
despeckling and has support for many input and output formats. It can be used
with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
- (license (list license:gpl2+ ;for the utility itself
- license:lgpl2.1+))))) ;for use as a library
+ (license (list license:gpl2+ ;for the utility itself
+ license:lgpl2.1+)))) ;for use as a library
(define-public embree
(package
diff --git a/gnu/packages/patches/autotrace-glib-compat.patch b/gnu/packages/patches/autotrace-glib-compat.patch
deleted file mode 100644
index e63dcedf83..0000000000
--- a/gnu/packages/patches/autotrace-glib-compat.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Fix build with GLib 2.68 and later.
-
-Taken from upstream pull request:
-https://github.com/autotrace/autotrace/pull/41
-
-diff --git a/src/autotrace.h b/src/autotrace.h
---- a/src/autotrace.h
-+++ b/src/autotrace.h
-@@ -23,6 +23,9 @@
-
- #include <stdio.h>
-
-+#include "types.h"
-+#include "color.h"
-+
- #ifdef __cplusplus
- extern "C" {
- #endif /* __cplusplus */
-@@ -35,9 +38,6 @@ extern "C" {
- * Typedefs
- * ===================================================================== */
-
--#include "types.h"
--#include "color.h"
--
- /* Third degree is the highest we deal with. */
- enum _at_polynomial_degree {
- AT_LINEARTYPE = 1,
-diff --git a/src/color.h b/src/color.h
---- a/src/color.h
-+++ b/src/color.h
-@@ -24,6 +24,10 @@
- #include <glib.h>
- #include <glib-object.h>
-
-+#ifdef __cplusplus
-+extern "C" {
-+#endif /* __cplusplus */
-+
- typedef struct _at_color at_color;
- struct _at_color {
- guint8 r;
-@@ -43,4 +47,7 @@ void at_color_free(at_color * color);
- GType at_color_get_type(void);
- #define AT_TYPE_COLOR (at_color_get_type ())
-
-+#ifdef __cplusplus
-+}
-+#endif /* __cplusplus */
- #endif /* not AT_COLOR_H */