summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:51:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:37 +0200
commit831a550c22226a8eae00c31c1ab463b117bd0558 (patch)
tree002f7e9e08ad0f676d42bbc3d422a7119923ea32
parent41ebbdc6c035f8661daaf68e5c9cb9cf7974ad6f (diff)
gnu: Add texlive-playfair.
* gnu/packages/tex.scm (texlive-playfair): New variable.
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 13b732bd4e..d25e6b3338 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21219,6 +21219,37 @@ paragraphs vertically separated rather than indented.")
typesetting of plays, including options for line numbering.")
(license license:lppl)))
+(define-public texlive-playfair
+ (package
+ (name "texlive-playfair")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/playfair/"
+ "fonts/enc/dvips/playfair/"
+ "fonts/map/dvips/playfair/"
+ "fonts/opentype/public/playfair/"
+ "fonts/tfm/public/playfair/"
+ "fonts/type1/public/playfair/"
+ "fonts/vf/public/playfair/"
+ "tex/latex/playfair/")
+ (base32
+ "060l6q6m410nn31mn09v3gy5nvbimplraifqcqlp3h8pzcrc3akf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/playfair")
+ (synopsis "Playfair Display fonts with LaTeX support")
+ (description
+ "This package provides the PlayFairDisplay family of fonts, designed by
+Claus Eggers Sorensen, for use with LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX.
+PlayFairDisplay is well suited for titling and headlines. It has an extra
+large x-height and short descenders. It can be set with no leading if space
+is tight, for instance in news headlines, or for stylistic effect in titles.
+Capitals are extra short, and only very slightly heavier than the lowercase
+characters. This helps achieve a more even typographical colour when
+typesetting proper nouns and initialisms.")
+ (license (list license:silofl1.1 license:lppl))))
+
(define-public texlive-pm-isomath
(package
(name "texlive-pm-isomath")