summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:27:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:42:51 +0200
commit868e0bf179670f12a0680a44b79d6e71f1f5aa58 (patch)
tree5fb1dd193e22650d49cea2b0cd152beec265aa40
parent4dd47ed354479aeec009523b80b1c2fb5bdbec74 (diff)
gnu: Add texlive-persian-bib.
* gnu/packages/tex.scm (texlive-persian-bib): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2bb993c025..f9b76868a2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8885,6 +8885,29 @@ will behave in the same way. The package also offers a robust
reimplementation of @code{\\big}, @code{\\bigg}, etc.")
(license license:lppl1.3+)))
+(define-public texlive-persian-bib
+ (package
+ (name "texlive-persian-bib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/persian-bib/"
+ "bibtex/csf/persian-bib/"
+ "doc/xelatex/persian-bib/")
+ (base32
+ "18x592g8y1i8kw724an65q84jj91cam5qvwp9mgnhqpwh3gjflpw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/persian-bib")
+ (synopsis "Persian translations of classic BibTeX styles")
+ (description
+ "This package provides BibTeX styles modified for Persian documents
+prepared with XePersian (which the present package depends on). The Persian
+@file{.bst} files can simultaneously handle both Latin and Persian references.
+A file @file{p1256fa.csf} is provided for correct sorting of Persian
+references and three fields LANGUAGE, TRANSLATOR and AUTHORFA are defined.")
+ (license license:lppl1.3+)))
+
(define-public texlive-pfdicons
(package
(name "texlive-pfdicons")