summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 00:20:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:00 +0200
commit8a7628247ea6f1cfb41bdd0ac022bc09f2938ffa (patch)
tree736b18a23cb5a7f9d3fec8556b5c94e0d1d44ea2
parent5c0d75bf1e1039ebb61bd4533d24cc85ecf29886 (diff)
gnu: texlive-filecontents: Refresh package definition.
* gnu/packages/tex.scm (texlive-filecontents): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0e705ea25c..186274bead 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3454,29 +3454,29 @@ a process to convert the EPS to PDF, using the script @command{epstopdf}.")
(define-deprecated-package texlive-latex-epstopdf-pkg texlive-epstopdf-pkg)
(define-public texlive-filecontents
- (let ((template (simple-texlive-package
- "texlive-filecontents"
- (list "doc/latex/filecontents/"
- "source/latex/filecontents/"
- "tex/latex/filecontents/")
- (base32
- "0ifhqfdzx91hrmndhg5441rpmv9k4lxrql02kd5yx75xpplxryzw"))))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '()) "latex/filecontents")))
- (home-page "https://ctan.org/pkg/filecontents")
- (synopsis "Create an external file from within a LaTeX document")
- (description
- "LaTeX2e's @code{filecontents} and @code{filecontents*} environments
+ (package
+ (name "texlive-filecontents")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/filecontents/"
+ "source/latex/filecontents/"
+ "tex/latex/filecontents/")
+ (base32
+ "0ifhqfdzx91hrmndhg5441rpmv9k4lxrql02kd5yx75xpplxryzw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/filecontents")
+ (synopsis "Create an external file from within a LaTeX document")
+ (description
+ "LaTeX2e's @code{filecontents} and @code{filecontents*} environments
enable a LaTeX source file to generate external files as it runs through
LaTeX. However, there are two limitations of these environments: they refuse
to overwrite existing files, and they can only be used in the preamble of
a document. The filecontents package removes these limitations, letting you
overwrite existing files and letting you use @code{filecontents}
@code{filecontents*} anywhere.")
- (license license:lppl1.3c+))))
+ (license license:lppl1.3c+)))
(define-deprecated-package texlive-latex-filecontents texlive-filecontents)