summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 15:15:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:04 +0200
commit933b845d3a5174e6175014b6431d22ad5841db30 (patch)
tree53d27c106bc26adf843d3bf0cf76eb0b2e89d2c8
parentf278a1f7160607556d756acf9edb3bbd1443c167 (diff)
gnu: texlive-endnotes: Refresh package definition.
* gnu/packages/tex.scm (texlive-endnotes): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c564b05664..7bdf4a1674 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7631,20 +7631,23 @@ provides means for easy customization of the list of notes.")
(define-public texlive-endnotes
(package
- (inherit (simple-texlive-package
- "texlive-endnotes"
- (list "doc/latex/endnotes/"
- "tex/latex/endnotes/")
- (base32
- "1s7j5sg8fbhifng0gfqnghbvalbbh0p7j9v06r660w089364ypwz")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/endnotes")
- (synopsis "Deal with endnotesings in strings")
+ (name "texlive-endnotes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/endnotes/" "tex/latex/endnotes/")
+ (base32
+ "1s7j5sg8fbhifng0gfqnghbvalbbh0p7j9v06r660w089364ypwz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/endnotes")
+ (synopsis "Place footnotes at the end")
(description
- "Accumulates notes (using the @code{\\endnote} command, which can be used
-as a replacement for @code{\\footnote}), and places them at the end of
-the section, chapter or document.")
- (license license:lppl1.0+)))
+ "The @code{endnotes} package can be used to accumulate notes (using the
+@code{\\endnote} command, which can be used as a replacement for
+@code{\\footnote}), and place them at the end of the section, chapter or
+document.")
+ (license license:lppl1.2+)))
(define-public texlive-enumitem
(package