summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-25 16:04:30 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-25 16:04:48 +0100
commit970d89b9faaf1e9705134c71fa895861dd83463b (patch)
tree8c8e85384cda77bdb23357774d96194b7a16492f
parent3e5fd70f52f9c117cb8803551c447861b68a07d5 (diff)
gnu: python-json-spec: Update to 0.11.0.
* gnu/packages/python-xyz.scm (python-json-spec): Update to 0.11.0. [propagated-inputs]: Remove python-pathlib and python-six; add python-importlib-metadata and python-termcolor.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b43453a726..1c4dcd50fe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13608,20 +13608,21 @@ Debian-related files, such as:
(define-public python-json-spec
(package
(name "python-json-spec")
- (version "0.10.1")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "json-spec" version))
+ (uri (pypi-uri "json_spec" version))
(sha256
(base32
- "06dpbsq61ja9r89wpa2pzdii47qh3xri9ajdrgn1awfl102znchb"))))
+ "0fwxirzxx5s9l0lwnjl6ki39xw1fsjm0vr6cm67ws27fkmcxcry7"))))
(build-system python-build-system)
(propagated-inputs
- (list python-pathlib python-six))
+ (list python-importlib-metadata
+ python-termcolor))
(native-inputs
(list python-pytest))
- (home-page "http://py.errorist.io/json-spec")
+ (home-page "https://json-spec.readthedocs.io/")
(synopsis
"JSON Schema, JSON Pointer and JSON Reference for Python")
(description