summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-09 00:40:19 +0100
committerChristopher Baines <mail@cbaines.net>2023-10-11 12:11:42 +0100
commit9e2f605b28bc87f6a7fef82a77cb9635b7c1e418 (patch)
treec41a14596e759bba4926289edb352321417e6b90
parent46bdcee9c8480bf383424a0d68b2c9f54e818672 (diff)
gnu: python-stpipe: Update to 0.5.1.
* gnu/packages/astronomy.scm (python-stpipe): Update to 0.5.1. [arguments]{test-flags}: Disable on failing test. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fdf3f7d4e2..ea96f3add7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2660,13 +2660,17 @@ implemented in the @acronym{JWST, James Webb Space Telescope} and
(define-public python-stpipe
(package
(name "python-stpipe")
- (version "0.5.0")
+ (version "0.5.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "stpipe" version))
(sha256
(base32
- "17gnwzhl10vbg059lfprdyci19dlh3whkmb9rl7z25wr593rnvcp"))))
+ "11ccb3v2s20lf851061s4nanljwm9s9xzkcfgb3qhv0hjwziq0vr"))))
+ (arguments
+ (list
+ ;; See https://github.com/spacetelescope/stpipe/issues/114
+ #:test-flags #~(list "-k" "not test_roman_datamodel")))
(build-system pyproject-build-system)
(propagated-inputs (list python-asdf python-astropy python-crds
python-semantic-version python-stdatamodels))