summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-03-20 17:00:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-20 18:25:10 +0100
commit9f09ac6b218e8538028394ce0aec4b6a8c479f54 (patch)
treefb5f909e9f72dc5b132309b41e5e5f09e052d0b4
parent284b5eca603ade3460474f0b97c85e17dd2dde39 (diff)
gnu: Add r-affyplm.
* gnu/packages/bioconductor.scm (r-affyplm): New variable.
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 20d1df89b8..f37cc98e3e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2125,6 +2125,37 @@ employed to first background subtract intensities before calculating
concentrations on behal of the Langmuir model.")
(license license:gpl3)))
+(define-public r-affyplm
+ (package
+ (name "r-affyplm")
+ (version "1.74.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affyPLM" version))
+ (sha256
+ (base32 "0f0faxjzlg0znhjfvf1490yc54npkx659jx76cddm5hk7q0blv3v"))))
+ (properties `((upstream-name . "affyPLM")))
+ (build-system r-build-system)
+ (inputs (list zlib))
+ (propagated-inputs
+ (list r-affy
+ r-biobase
+ r-biocgenerics
+ r-gcrma
+ r-preprocesscore
+ r-zlibbioc))
+ (home-page "https://github.com/bmbolstad/affyPLM")
+ (synopsis "Methods for fitting probe-level models")
+ (description
+ "The affyPLM provides a package that extends and improves the
+functionality of the base affy package. For speeding up the runs, it includes
+routines that make heavy use of compiled code. The central focus is on
+implementation of methods for fitting probe-level models and tools using these
+models. @acronym{PLM, probe-level models} based quality assessment tools are
+also provided.")
+ (license license:gpl2+)))
+
(define-public r-affyrnadegradation
(package
(name "r-affyrnadegradation")