summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:08 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:26 +0200
commita08db1e4a18bb80f87f8e9d32684749c1adce9ab (patch)
tree2de14af5b4266e77b6d1653eff9d01f87d76c33f
parent64a042401d03773709a318a48f779b1f64ca2b4e (diff)
gnu: Add trytond-account-statement.
* gnu/packages/tryton.scm (trytond-account-statement): New variable.
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 09c3e57f02..6e142ac0f2 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -971,6 +971,33 @@ and category.")
(define-public python-trytond-account-product
(deprecated-package "python-trytond-account-product" trytond-account-product))
+(define-public trytond-account-statement
+ (package
+ (name "trytond-account-statement")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_statement" version))
+ (sha256
+ (base32 "0nlak4kv2ampb5v2zbsvabnirvdi53h6vr35kp2zmrv4alpjsla0"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_statement"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-account-invoice" ,trytond-account-invoice)
+ ("trytond-bank" ,trytond-bank)
+ ("trytond-company" ,trytond-company)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-party" ,trytond-party)))
+ (home-page "https://docs.tryton.org/projects/modules-account-statement")
+ (synopsis "Tryton module with account statements")
+ (description "The @emph{Account Statement} Tryton module allows to book
+statements. Statement can be used for bank statement, cash daybook etc.")
+ (license license:gpl3+)))
+
(define-public trytond-analytic-account
(package
(name "trytond-analytic-account")