summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-01-08 02:53:13 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:50 +0200
commita47649dd5cdb86e3d4673cd394a621c32fb08974 (patch)
treeb2051044cc84a9c2c83072265bde4022e098d555
parent3902a1413ea826b943bdf4995725eeafb296c55c (diff)
gnu: Add rust-poly1305-0.8.
* gnu/packages/crates-io.scm (rust-poly1305-0.8): New variable. (rust-poly1305-0.7): Inherit from rust-poly1305-0.8. Change-Id: I853879812db8636e3a5ef8743ac5215f97156685 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 27 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b034b980d1..37cdc581de 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -51691,8 +51691,34 @@ library.")
(description "Proc-macro crate for pollster.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-poly1305-0.8
+ (package
+ (name "rust-poly1305")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "poly1305" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1grs77skh7d8vi61ji44i8gpzs3r9x7vay50i6cg8baxfa8bsnc1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-universal-hash" ,rust-universal-hash-0.5)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))
+ (home-page "https://github.com/RustCrypto/universal-hashes")
+ (synopsis "Poly1305 universal hash")
+ (description
+ "Poly1305 is a universal hash function which, when combined with
+a cipher, can be used as a Message Authentication Code (MAC).")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-poly1305-0.7
(package
+ (inherit rust-poly1305-0.8)
(name "rust-poly1305")
(version "0.7.2")
(source
@@ -51706,7 +51732,6 @@ library.")
(snippet
'(begin (substitute* "Cargo.toml"
(("version = \">=1, <1\\.4\"") "version = \"^1\""))))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-cpufeatures" ,rust-cpufeatures-0.2)
@@ -51714,13 +51739,7 @@ library.")
("rust-universal-hash" ,rust-universal-hash-0.4)
("rust-zeroize" ,rust-zeroize-1))
#:cargo-development-inputs
- (("rust-hex-literal" ,rust-hex-literal-0.3))))
- (home-page "https://github.com/RustCrypto/universal-hashes")
- (synopsis "Poly1305 universal hash")
- (description
- "Poly1305 is a universal hash function which, when combined with
-a cipher, can be used as a Message Authentication Code (MAC).")
- (license (list license:asl2.0 license:expat))))
+ (("rust-hex-literal" ,rust-hex-literal-0.3))))))
(define-public rust-polyval-0.6
(package