summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 22:02:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:34 +0100
commita6d1c4e75a76399c8d82a9570db5cd14351f661b (patch)
tree750cbe184f48b4afec0c0d646749ca582053546d
parent44c233ac139d67669adc3da454adde07d74bb1c4 (diff)
gnu: Add ghc-th-lift-instances.
* gnu/packages/haskell.scm (ghc-th-lift-instances): New variable.
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 71dc2799e6..83b3e9a752 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4957,6 +4957,32 @@ Template Haskell.")
datatypes.")
(license license:bsd-3)))
+(define-public ghc-th-lift-instances
+ (package
+ (name "ghc-th-lift-instances")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "th-lift-instances/th-lift-instances-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1f56cp6ckcalld5jchv0kxpjkwcsixd7smd0g7r8cg67ppx6m90x"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-th-lift" ,ghc-th-lift)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-text" ,ghc-text)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/bennofs/th-lift-instances/")
+ (synopsis "Lift instances for template-haskell for common data types.")
+ (description "Most data types in the Haskell platform do not have Lift
+instances. This package provides orphan instances for @code{containers},
+@code{text}, @code{bytestring} and @code{vector}.")
+ (license license:bsd-3)))
+
(define-public ghc-th-expand-syns
(package
(name "ghc-th-expand-syns")