summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:43:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:41 +0200
commitad600f9b1bd5d2e5638c1618253cee679a3e1f2b (patch)
treeeef5ce4825af64f98971a70bf48cd2f3ae1c174d
parent576a337974ea4f764aaf4fa49b7ecf316735125e (diff)
gnu: Add texlive-songs.
* gnu/packages/tex.scm (texlive-songs): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8b53487781..b73560a371 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12402,6 +12402,36 @@ slides with overlays. The package comes with an additional Python script that
can be used to convert plain-text song lyrics to the expected LaTeX markup.")
(license license:bsd-3)))
+(define-public texlive-songs
+ (package
+ (name "texlive-songs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/songs/" "source/latex/songs/"
+ "tex/latex/songs/")
+ (base32
+ "0mgzkh6cvq3smwjlkvd1gnhb7m151fgiv7f4v3drjqlsjyg2qds6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/songs")
+ (synopsis "Produce song books for church or fellowship")
+ (description
+ "The package provides a means of producing beautiful song books for
+church or fellowship. It offers:
+@itemize
+@item a very easy chord-entry syntax;
+@item multiple modes (words-only; words+chords; slides; handouts);
+@item measure bars;
+@item guitar tablatures;
+@item automatic transposition;
+@item scripture quotations;
+@item multiple indexes (sorted by title, author, important lyrics, or
+scripture references);
+@item and projector-style output generation, for interactive use.
+@end itemize")
+ (license license:gpl2)))
+
(define-public texlive-spalign
(package
(name "texlive-spalign")