summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:01 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:17 -0500
commitb184a16c141d110840b023851b233dfe032a2f72 (patch)
treed2cd66848d87bc468ebf77770bdd7849f3d79681
parentfd51ae6a374cb2f151884dc27de2ff11141f5f5c (diff)
gnu: go-github-com-tdewolff-parse-v2: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-tdewolff-parse-v2): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Id58c54359f1bf55c6fc8178ce142bf985858bb87
-rw-r--r--gnu/packages/golang-web.scm38
-rw-r--r--gnu/packages/golang.scm37
2 files changed, 38 insertions, 37 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d82cac46b9..9e68e96baf 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -509,6 +509,44 @@ to jQuery to the Go language.")
an interface to implement any other minifier.")
(license license:expat)))
+(define-public go-github-com-tdewolff-parse-v2
+ (package
+ (name "go-github-com-tdewolff-parse-v2")
+ (version "2.6.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdewolff/parse")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dqki9ima079k9a3l72igmx5dml8qsl9z8rzw8a433f4gjhlv320"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tdewolff/parse/v2"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'regenerate-hash
+ (lambda* (#:key import-path #:allow-other-keys)
+ (for-each
+ (lambda (dir)
+ (with-directory-excursion
+ (format #f "src/~a/~a" import-path dir)
+ (make-file-writable "hash.go")
+ (format #t "Generating `hash.go' for ~a...~%" dir)
+ (invoke "go" "generate")))
+ '("css" "html")))))))
+ (native-inputs
+ (list go-github-com-tdewolff-hasher
+ go-github-com-tdewolff-test))
+ (home-page "https://github.com/tdewolff/parse")
+ (synopsis "Go parsers for web formats")
+ (description
+ "This package contains several lexers and parsers written in Go.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 74bd542d42..acffd91dde 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3573,43 +3573,6 @@ per-goroutine.")
@code{string} to @code{uint32} mapper.")
(license license:bsd-3)))
-(define-public go-github-com-tdewolff-parse-v2
- (package
- (name "go-github-com-tdewolff-parse-v2")
- (version "2.6.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tdewolff/parse")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1dqki9ima079k9a3l72igmx5dml8qsl9z8rzw8a433f4gjhlv320"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/tdewolff/parse/v2"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'regenerate-hash
- (lambda* (#:key import-path #:allow-other-keys)
- (for-each
- (lambda (dir)
- (with-directory-excursion
- (format #f "src/~a/~a" import-path dir)
- (make-file-writable "hash.go")
- (format #t "Generating `hash.go' for ~a...~%" dir)
- (invoke "go" "generate")))
- '("css" "html")))))))
- (native-inputs
- (list go-github-com-tdewolff-hasher
- go-github-com-tdewolff-test))
- (home-page "https://github.com/tdewolff/parse")
- (synopsis "Go parsers for web formats")
- (description
- "This package contains several lexers and parsers written in Go.")
- (license license:expat)))
-
(define-public go-github-com-tj-docopt
(package
(name "go-github-com-tj-docopt")