summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 00:00:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:57 +0200
commitb28445b50f341fef5f0d6604949c7220c3e78c86 (patch)
treeed693dfd8326bf41ec46f83ae6cf47dfbf8c3649
parentf2a8c918c22bc237a3f158d08f9bf3e643f7679e (diff)
gnu: texlive-pdfx: Refresh package definition.
* gnu/packages/tex.scm (texlive-pdfx): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-COLORPROFILES, TEXLIVE-EVERYSHI, TEXLIVE-HYPERREF, TEXLIVE-IFTEX, TEXLIVE-PDFTEXCMDS, TEXLIVE-STRINGENC, TEXLIVE-XCOLOR, TEXLIVE-XMPINCL. Remove TEXLIVE-PDFTEX.
-rw-r--r--gnu/packages/tex.scm59
1 files changed, 33 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d5b36c118..5fc57d736d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10207,33 +10207,40 @@ the file to which it applies.")
(define-deprecated-package texlive-latex-xmpincl texlive-xmpincl)
(define-public texlive-pdfx
- (let ((template (simple-texlive-package
- "texlive-pdfx"
- (list "/doc/latex/pdfx/"
- "/source/latex/pdfx/"
- "/tex/latex/pdfx/")
- (base32
- "1z4j4d92k2fjmf8jfap4zn7ij97d9rz2jcs9aslcac07ag4x5bdp"))))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ #t)
- "latex/pdfx")
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'fix-encoding
- (lambda _
- (substitute* "source/latex/pdfx/pdfx.dtx"
- ((" .+umaczy") "umaczy"))))))))
- (propagated-inputs
- (list texlive-pdftex))
- (home-page "https://www.ctan.org/pkg/pdfx")
- (synopsis "PDF/X and PDF/A support for pdfTeX, LuaTeX and XeTeX")
- (description
- "This package helps LaTeX users to create PDF/X, PDF/A and other
+ (package
+ (name "texlive-pdfx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pdfx/" "source/latex/pdfx/"
+ "tex/latex/pdfx/")
+ (base32
+ "1z4j4d92k2fjmf8jfap4zn7ij97d9rz2jcs9aslcac07ag4x5bdp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-encoding
+ (lambda _
+ (substitute* "source/latex/pdfx/pdfx.dtx"
+ ((" .+umaczy") "umaczy")))))))
+ (propagated-inputs
+ (list texlive-colorprofiles
+ texlive-everyshi
+ texlive-hyperref
+ texlive-iftex
+ texlive-pdftexcmds
+ texlive-stringenc
+ texlive-xcolor
+ texlive-xmpincl))
+ (home-page "https://ctan.org/pkg/pdfx")
+ (synopsis "PDF/X and PDF/A support for pdfTeX, LuaTeX and XeTeX")
+ (description
+ "The package helps LaTeX users to create PDF/X, PFD/A and other
standards-compliant PDF documents with pdfTeX, LuaTeX and XeTeX.")
- (license license:lppl1.2+))))
+ (license license:lppl1.2+)))
(define-deprecated-package texlive-latex-pdfx texlive-pdfx)