summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-08 12:27:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:17 +0300
commitb2de124e15e8f7794c75a91ba2534203f26cda14 (patch)
tree402106b03950c6818753bbf4fb4dc48b0719a88c
parent04ace10cac8b8518301918e33974e352026f34a4 (diff)
gnu: rust-afl-0.12: Remove check-for-pregenerated-files phase.
* gnu/packages/crates-io.scm (rust-afl-0.12)[arguments]: Add a phase to remove the 'check-for-pregenerated-files phase.
-rw-r--r--gnu/packages/crates-io.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 532bcd0694..cc888a305c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2484,7 +2484,10 @@ This package is deprecated and was replaced by the @code{aes} crate.")
#:cargo-development-inputs
(("rust-arbitrary" ,rust-arbitrary-1)
("rust-assert-cmd" ,rust-assert-cmd-2)
- ("rust-tempfile" ,rust-tempfile-3))))
+ ("rust-tempfile" ,rust-tempfile-3))
+ #:phases (modify-phases %standard-phases
+ ;; Custom archive file for test suite.
+ (delete 'check-for-pregenerated-files))))
(home-page "https://github.com/rust-fuzz/afl.rs")
(synopsis
"Fuzzing Rust code with american-fuzzy-lop")