summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-07 00:33:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-07 00:49:48 +0100
commitb334184d1cf01c88980509f693ec670cdb9ce9b6 (patch)
tree50bf76fd091c582de36ca5cf5e6e51ed3893715e
parent5b057c19831dc9f8035e006a9125c12ca47b82fd (diff)
gnu: emacs-compat: Update to 29.1.0.1.
* gnu/packages/emacs-xyz.scm (emacs-compat): Update to 29.1.0.1.
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7a6407ce47..cb40429485 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7794,24 +7794,25 @@ variables, and so on. The mode also allows you to execute Tup commands.")
(license license:gpl3+)))
(define-public emacs-compat
- (package
- (name "emacs-compat")
- (version "28.1.2.2")
- (source (origin
+ (let ((commit "8a32564247ad3baee571252a2004c3d347962d01")) ;version bump
+ (package
+ (name "emacs-compat")
+ (version "29.1.0.1")
+ (source (origin
(method git-fetch)
(uri (git-reference
(url "https://git.sr.ht/~pkal/compat")
- (commit version)))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "1c1pr6zzvgfbsclp1fyx911d4qvihz8hw5mp7g0l0df2rlpypdzw"))))
- (build-system emacs-build-system)
- (propagated-inputs (list emacs-nadvice))
- (home-page "https://git.sr.ht/~pkal/compat")
- (synopsis "Emacs Lisp Compatibility Library")
- (description
- "To allow for the usage of Emacs functions and macros that are defined
+ "0wxv63cqrw7pd5vg5hwh48bf326766x6mzz1qw8shhkrycr43fks"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nadvice))
+ (home-page "https://git.sr.ht/~pkal/compat")
+ (synopsis "Emacs Lisp Compatibility Library")
+ (description
+ "To allow for the usage of Emacs functions and macros that are defined
in newer versions of Emacs, @code{compat.el} provides definitions that
are installed ONLY if necessary. These reimplementations of functions
and macros are at least subsets of the actual implementations. Be
@@ -7822,7 +7823,7 @@ here. Some depend on new features from the core, others cannot be
implemented to a meaningful degree. The main audience for this
library are not regular users, but package maintainers. Therefore
commands and user options are usually not implemented here.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-company
(package