summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-22 21:17:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 20:51:22 -0400
commitb37b3d4891c03598e83a5400e4696e7925ad3469 (patch)
treeaa72c9599d3518f88702e94d6b92b50a3c5ac699
parentaf448f9c9589baeba5143189676256edf1c94766 (diff)
gnu: libdazzle: Update to 3.44.0.
* gnu/packages/gnome.scm (libdazzle): Update to 3.44.0. [inputs]: Move gobject-introspection and vala to... [native-inputs]: ... here.
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e8b551fca0..8bab6144e0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11056,7 +11056,7 @@ hexadecimal or ASCII. It is useful for editing binary files in general.")
(define-public libdazzle
(package
(name "libdazzle")
- (version "3.37.1")
+ (version "3.44.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libdazzle/"
@@ -11064,7 +11064,7 @@ hexadecimal or ASCII. It is useful for editing binary files in general.")
"libdazzle-" version ".tar.xz"))
(sha256
(base32
- "03r5cr11dc031qa3694bpgm3lajrhiiln67kvl7vjj4q0scf7w7x"))))
+ "1blfs61ifv4fywl0wbr1cm3rvmgrv06yiqajbnq0qs72nrgf9lrw"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -11073,15 +11073,17 @@ hexadecimal or ASCII. It is useful for editing binary files in general.")
(lambda _
;; Tests require a running X server.
(system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- #t)))))
+ (setenv "DISPLAY" ":1"))))))
(native-inputs
(list `(,glib "bin") ; glib-compile-resources
+ gobject-introspection
pkg-config
;; For tests.
- xorg-server-for-tests))
+ xorg-server-for-tests
+ vala))
(inputs
- (list glib gobject-introspection gtk+ vala))
+ (list glib
+ gtk+))
(home-page "https://gitlab.gnome.org/GNOME/libdazzle")
(synopsis "Companion library to GObject and Gtk+")
(description "The libdazzle library is a companion library to GObject and