summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-09 00:01:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:43 -0400
commitb4a174826d847861a92a4ff1d9f6ef1a150e7847 (patch)
tree547676cbc087f246cad1ec3b3a4887154048d517
parentc2a2c5fc22804e9cb03c00bdab638049cddeb374 (diff)
gnu: seahorse: Update to 42.0.
* gnu/packages/gnome.scm (seahorse): Update to 42.0. [phases]: Delete trailing #t. [inputs, native-inputs]: Remove labels.
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 399e0b487d..17ba6513e4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4409,7 +4409,7 @@ engineering.")
(define-public seahorse
(package
(name "seahorse")
- (version "41.0")
+ (version "42.0")
(source
(origin
(method url-fetch)
@@ -4417,7 +4417,7 @@ engineering.")
(version-major version) "/" name "-"
version ".tar.xz"))
(sha256
- (base32 "1x99i7kdvd8hbxcs5rfrq7nw6r9bfzaw263zaigjjj04h6gc1vp6"))))
+ (base32 "0c6nafhn4gcjwd1xbs5bjq9785114fc0pbhxbwp7wynyz3msq365"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -4427,32 +4427,31 @@ engineering.")
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "build-aux/meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-before 'check 'pre-check
(lambda _
;; Tests require a writable HOME.
(setenv "HOME" (getcwd)))))))
(inputs
- `(("gtk+" ,gtk+)
- ("gcr" ,gcr)
- ("gnupg" ,gnupg)
- ("gpgme" ,gpgme)
- ("openldap" ,openldap)
- ("openssh" ,openssh)
- ("avahi" ,avahi)
- ("libhandy" ,libhandy)
- ("libpwquality" ,libpwquality)
- ("libsecret" ,libsecret)
- ("libsoup" ,libsoup-minimal-2)))
+ (list gtk+
+ gcr
+ gnupg
+ gpgme
+ openldap
+ openssh
+ avahi
+ libhandy
+ libpwquality
+ libsecret
+ libsoup-minimal-2))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("itstool" ,itstool)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("vala" ,vala)
- ("xmllint" ,libxml2)))
+ (list gettext-minimal
+ `(,glib "bin")
+ itstool
+ pkg-config
+ python
+ vala
+ libxml2))
(home-page "https://wiki.gnome.org/Apps/Seahorse")
(synopsis "Manage encryption keys and passwords in the GNOME keyring")
(description