summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-09 22:29:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:07 +0200
commitb60ea1cd17b3d988f210aa76eac4f68d0c1a0718 (patch)
tree51f716f73c457fb0f0ecfe6219ca63444bf44f0a
parente43ceae59f4b7e69fea25f8242db9073fab06f48 (diff)
gnu: python-traitlets: Update to 5.9.0.
* gnu/packages/python-xyz.scm (python-traitlets): Update to 5.9.0. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-hatchling, python-pre-commit, and python-pytest-mock. [arguments]: Remove custom 'check phase.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 74103403bb..ac9d077151 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9704,23 +9704,20 @@ connect strings, then issue SQL commands within IPython or IPython Notebook.")
(define-public python-traitlets
(package
(name "python-traitlets")
- (version "5.1.1")
+ (version "5.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "traitlets" version))
(sha256
(base32
- "1ivhxglsrnhqw4g98ihddn7i5f6976gpk31fijwq473wb9n4b7q5"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "traitlets")))))))
+ "1ndslgsan1g5xhrvxrv2x03zcfvjb8nzfd90y1m7bkv8khdf5kgn"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest))
+ (list python-hatchling
+ python-pre-commit
+ python-pytest
+ python-pytest-mock))
(home-page "https://ipython.org")
(synopsis "Configuration system for Python applications")
(description