summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 21:27:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:34 +0100
commitb9a64a367143e8a230ab32ea1c70a8b774ae5a66 (patch)
tree7ea8cd34c7ffb86f8e87f58aa376d2066bddd56b
parent567bf5b975bdfda14a8f7aecb84dfa976208d6fa (diff)
gnu: Add ghc-haskell-lexer.
* gnu/packages/haskell.scm (ghc-haskell-lexer): New variable.
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b27185848b..bd3ebae821 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -926,6 +926,26 @@ specification in BNF, Happy generates Haskell code to parse the grammar.
Happy works in a similar way to the yacc tool for C.")
(license license:bsd-3)))
+(define-public ghc-haskell-lexer
+ (package
+ (name "ghc-haskell-lexer")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/haskell-lexer/haskell-lexer-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0rj3r1pk88hh3sk3mj61whp8czz5kpxhbc78xlr04bxwqjrjmm6p"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/haskell-lexer")
+ (synopsis "Fully compliant Haskell 98 lexer")
+ (description
+ "This package provides a fully compliant Haskell 98 lexer.")
+ (license license:bsd-3)))
+
(define-public ghc-haskell-src-exts
(package
(name "ghc-haskell-src-exts")