summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-11-08 15:06:12 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-11-08 15:20:54 +0100
commitbbc8a1252422f186871b2fb09d1dc5de24dcdfbf (patch)
treed591aa3c9149b2a8ea42323e0ee958dedc590246
parent9fef2524b12b97904f07e0a07345f7fc9a9630aa (diff)
gnu: emacs-org-web-tools: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-org-web-tools)[arguments]: Use G-expressions. Remove trailing #T from phases. [description]: Use proper quoting and name for Org project. Change-Id: Ifdec8ab61fc44f2a73da87a1fd042140e691e5ae
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e0885723ef..2ba3e1f107 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28174,23 +28174,24 @@ This package also includes a @code{yt-dlp} front-end.")
(inputs
(list pandoc))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((pandoc (assoc-ref inputs "pandoc")))
- (substitute* "org-web-tools.el"
- (("\"pandoc\"") (string-append "\"" pandoc "/bin/pandoc\"")))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pandoc (search-input-file inputs "/bin/pandoc")))
+ (substitute* "org-web-tools.el"
+ (("\"pandoc\"") (string-append "\"" pandoc "\"")))))))))
(home-page "https://github.com/alphapapa/org-web-tools")
- (synopsis "Display/Process web page as Org-mode content")
- (description "This package contains library functions and commands useful
-for retrieving web page content and processing it into Org-mode content.
-
-For example, you can copy a URL to the clipboard or kill-ring, then run a
-command that downloads the page, isolates the “readable” content with
-@command{eww-readable}, converts it to Org-mode content with Pandoc, and
-displays it in an Org-mode buffer. Another command does all of that but
+ (synopsis "Display/Process web page as Org mode content")
+ (description
+ "This package contains library functions and commands useful
+for retrieving web page content and processing it into Org mode content.
+
+For example, you can copy a URL to the clipboard or kill-ring, then run
+a command that downloads the page, isolates the ``readable'' content with
+@command{eww-readable}, converts it to Org mode content with Pandoc, and
+displays it in an Org mode buffer. Another command does all of that but
inserts it as an Org entry instead of displaying it in a new buffer.")
(license license:gpl3+)))