summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:19:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:39 +0200
commitbbf868fcdb429ebc0da459c41fcd8e7adb110cf7 (patch)
tree272470985e52751fb5635954d01cea7b9cc06eab
parent40d46e6522020c85da8c19506d2a57bf26296f5c (diff)
gnu: Add texlive-yamlvars.
* gnu/packages/tex.scm (texlive-yamlvars): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 08fe4ac441..ed2625b7e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13567,6 +13567,25 @@ standards-compliant PDF documents with pdfTeX, LuaTeX and XeTeX.")
(define-deprecated-package texlive-latex-pdfx texlive-pdfx)
+(define-public texlive-yamlvars
+ (package
+ (name "texlive-yamlvars")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/yamlvars/"
+ "tex/lualatex/yamlvars/")
+ (base32
+ "0r9xqjbag1kvyiz369nbz1w15ij5b3bw9msxrnz4864wn2b50cf0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/yamlvars")
+ (synopsis "YAML parser and tool for easy LaTeX definition creation")
+ (description
+ "This LuaLaTeX package provides a YAML parser and some functions to
+declare and define LaTeX definitions using YAML files.")
+ (license license:expat)))
+
(define-public texlive-yax
(package
(name "texlive-yax")