summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 13:50:37 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:50 +0530
commitbe54916f7ad6c642567870867811e41d93e1384b (patch)
treea098045aa9305042a8d6cbd843711848515ba39c
parentf736ef388d5faee385d111b3c57780fc0a700c93 (diff)
gnu: Add rust-aesni-0.7.
* gnu/packages/crates-io.scm (rust-aesni-0.7): New variable.
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 523dacd508..94700b1d25 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -220,6 +220,33 @@ the Rust programming language.")
AES (Rijndael) block ciphers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-aesni-0.7
+ (package
+ (name "rust-aesni")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "aesni" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r6j0mjkyqnwvgib01cvrwfw8rlx1biw75234niv723n1fdx6l6h"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-block-cipher" ,rust-block-cipher-0.7)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.2)
+ ("rust-stream-cipher" ,rust-stream-cipher-0.4))
+ #:cargo-development-inputs
+ (("rust-block-cipher" ,rust-block-cipher-0.7)
+ ("rust-stream-cipher" ,rust-stream-cipher-0.4))))
+ (home-page "https://github.com/RustCrypto/block-ciphers")
+ (synopsis "AES (Rijndael) block ciphers implementation using AES-NI")
+ (description "This package provides an implementation of AES (Rijndael)
+block ciphers using AES-NI.")
+ (license (list license:expat license:asl2.0))))
+
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t