summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:13:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 19:42:48 +0200
commitc0850a2afba877c7a722819bb5a574d746dea861 (patch)
tree9bbef922bfcea7366a95f97582c44c9663f4e781
parent0107b1752b0b0238d59662a5f6db07d8ab5aa0bb (diff)
gnu: Add texlive-arabic-book.
* gnu/packages/tex.scm (texlive-arabic-book): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8beddefee5..4eda92433d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2114,6 +2114,32 @@ copied from them and pasted elsewhere.")
contents for Arabic texts created by the @code{arabi} package.")
(license license:lppl1.3)))
+(define-public texlive-arabic-book
+ (package
+ (name "texlive-arabic-book")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/arabic-book/"
+ "tex/xelatex/arabic-book/")
+ (base32
+ "070agzwpgdfvjqn2klxw2m1bavy0l9b9pqqikc7il3wx107m4ni1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/arabic-book")
+ (synopsis "Arabic @code{book} class")
+ (description
+ "This document class provides both Arabic and English support for TeX and
+LaTeX. Input may be in ASCII transliteration or other encodings
+(including UTF-8), and output may be Arabic, Hebrew, or any of several
+languages that use the Arabic script, as can be specified by the Polyglossia
+package. The Arabic font is presently available in any Arabic fonts style.
+In order to use Amiri font style, the user needs to install the amiri package.
+This document class runs with the XeTeX engine. PDF files generated using
+this class can be searched, and text can be copied from them and pasted
+elsewhere.")
+ (license license:lppl1.3+)))
+
(define-public texlive-arara
(package
(name "texlive-arara")