summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 01:23:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:32 -0400
commitd1623e30767a00c2e7a49ec3d61248ba0523bbe0 (patch)
tree64acfa8dcffb33f9cd8f4f03c3f605e78b957cf0
parent212f9c62bf682ea333ae4414e08a9aa74e7ee506 (diff)
gnu: gnome-clocks: Update to 42.0.
* gnu/packages/gnome.scm (gnome-clocks): Update to 42.0. [phases]{skip-gtk-update-icon-cache}: Adjust. [native-inputs]: Remove labels and sort. Replace vala with vala-next. [inputs]: Sort. Remove libhandy. Replace libgweather with libgweather4-with-libsoup2. Replace gtk+ with gtk. Add libadwaita.
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2ea80147c5..daafca355b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9927,7 +9927,7 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
(define-public gnome-clocks
(package
(name "gnome-clocks")
- (version "40.0")
+ (version "42.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -9935,7 +9935,7 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
name "-" version ".tar.xz"))
(sha256
(base32
- "02d3jg46sn8d9gd4dsaly22gg5vkbz2gpq4pmwpvncb4rsqk7sn2"))))
+ "1q3gvniwd4dkr1ghqpp05zr7qswdhaxqrn8j6bm3qbh39bdihw8f"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -9944,24 +9944,25 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "build-aux/post-install.py"
- (("gtk-update-icon-cache") "true")))))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")))))))
(native-inputs
- `(("vala" ,vala)
- ("pkg-config" ,pkg-config)
- ("glib" ,glib "bin") ; for glib-compile-resources
- ("desktop-file-utils" ,desktop-file-utils)
- ("gettext" ,gettext-minimal)
- ("itstool" ,itstool)))
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin") ; for glib-compile-resources
+ itstool
+ pkg-config
+ vala-next))
(inputs
- (list glib
- gtk+
- gsound
- geoclue
+ (list geoclue
geocode-glib-with-libsoup2
- libgweather
- libhandy
- gnome-desktop))
+ glib
+ gnome-desktop
+ gsound
+ gtk
+ libadwaita
+ libgweather4-with-libsoup2))
(home-page "https://wiki.gnome.org/Apps/Clocks")
(synopsis "GNOME's clock application")
(description