summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-16 23:13:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:15 -0400
commitd477018b57d5b4c13b4dd35aa1c4ee1a00ca76e2 (patch)
tree595e2c8e4e800a7da19620c876580212954bdfaf
parent52e8f4d42634a3b9c9f143084aa9a246cf29124a (diff)
gnu: poetry: Update to 1.1.12.
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.12. [arguments]: Delete phases. (python-msgpack-transitional): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm56
1 files changed, 12 insertions, 44 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0dc2f1c7cb..2de500b840 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12382,37 +12382,6 @@ reading and writing MessagePack data.")
(base32
"1109s2yynrahwi64ikax68hx0mbclz8p35afmpphw5dwynb49q7s"))))))
-;; This msgpack library's name changed from "python-msgpack" to "msgpack" with
-;; release 0.5. Some packages like borg still call it by the old name for now.
-;; <https://bugs.gnu.org/30662>
-(define-public python-msgpack-transitional
- (package
- (inherit python-msgpack)
- (name "python-msgpack-transitional")
- (version "0.5.6")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "msgpack" version))
- (sha256
- (base32
- "1hz2dba1nvvn52afg34liijsm7kn65cmn06dl0xbwld6bb4cis0f"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-msgpack)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'configure-transitional
- (lambda _
- ;; Keep using the old name.
- (substitute* "setup.py"
- (("TRANSITIONAL = False")
- "TRANSITIONAL = 1"))
- ;; This old version is not compatible with Python 3.9
- (substitute* '("test/test_buffer.py" "test/test_extension.py")
- ((".tostring\\(") ".tobytes("))
- (substitute* '("test/test_buffer.py" "test/test_extension.py")
- ((".fromstring\\(") ".frombytes("))
- #t))))))))
-
(define-public python-netaddr
(package
(name "python-netaddr")
@@ -17927,25 +17896,26 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(define-public poetry
(package
(name "poetry")
- (version "1.1.12")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "poetry" version))
(sha256
(base32
- "0rr54mvcfcv9cv6vw2122y28xvd2pwqpv2x8c8j5ayz3gwsy4rjw"))))
+ "0g0vczn6qa4b2bdkq4k7fm1g739vyxp2iiblwwsrcmw24jj81m8b"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ;PyPI does not have tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-setup-py
- (lambda _
- (substitute* "setup.py"
- ;; Relax some of the requirements.
- (("(keyring>=21.2.0),<22.0.0" _ keyring) keyring)
- (("(packaging>=20.4),<21.0" _ packaging) packaging)))))))
+ ;; #:phases
+ ;; (modify-phases %standard-phases
+ ;; (add-before 'build 'patch-setup-py
+ ;; (lambda _
+ ;; (substitute* "setup.py"
+ ;; ;; Relax some of the requirements.
+ ;; (("(keyring>=21.2.0),<22.0.0" _ keyring) keyring)
+ ;; (("(packaging>=20.4),<21.0" _ packaging) packaging)))))
+ ))
(propagated-inputs
(list python-cachecontrol
python-cachy
@@ -17954,9 +17924,7 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
python-entrypoints
python-html5lib
python-keyring
- ; Use of deprecated version of msgpack reported upstream:
- ; https://github.com/python-poetry/poetry/issues/3607
- python-msgpack-transitional
+ python-msgpack
python-packaging
python-pexpect
python-pip