summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 00:17:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:59 +0200
commitdab531f4a0c1e1526900d500a02319cfd9a8dcdd (patch)
tree81ffb32258bed700189816b01abe10e2b1e2c2a3
parente9af0271fd7c1b6d8ff24b7d29b44b980b8e8400 (diff)
gnu: texlive-atveryend: Refresh package definition.
* gnu/packages/tex.scm (texlive-atveryend): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f4d002d46d..6327392351 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3379,29 +3379,28 @@ customize their appearance in the enclosing document.")
(license license:lppl1.3+)))
(define-public texlive-atveryend
- (let ((template (simple-texlive-package
- "texlive-atveryend"
- (list "doc/latex/atveryend/"
- "source/latex/atveryend/"
- "tex/latex/atveryend/")
- (base32 "1rp805h0m99rxs107a798l951lyahlnp7irfklfadn2a2ljzhafn"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:build-targets _ #t)
- #~(list "atveryend.dtx"))))
- (home-page "https://ctan.org/macros/latex/contrib/atveryend")
- (synopsis "Hooks at the very end of a document")
- (description
- "This LaTeX packages provides two hooks for @code{\\end{document}} that
+ (package
+ (name "texlive-atveryend")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/atveryend/"
+ "source/latex/atveryend/"
+ "tex/latex/atveryend/")
+ (base32
+ "1rp805h0m99rxs107a798l951lyahlnp7irfklfadn2a2ljzhafn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/atveryend")
+ (synopsis "Hooks at the very end of a document")
+ (description
+ "This LaTeX packages provides two hooks for @code{\\end{document}} that
are executed after the hook of @code{\\AtEndDocument}:
@code{\\AfterLastShipout} can be used for code that is to be executed right
after the last @code{\\clearpage} before the @file{.aux} file is closed.
@code{\\AtVeryEndDocument} is used for code after closing and final reading of
the @file{.aux} file.")
- (license license:lppl1.3+))))
+ (license license:lppl1.3+)))
(define-deprecated-package texlive-latex-atveryend texlive-atveryend)