summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-22 17:51:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-24 12:28:08 +0200
commitdc18d10cbc5dbf0982c67023072e29d98149b9ab (patch)
tree6934dcc06e63305003b9d25c8940c068963f5647
parent8239f1f8cf95b73a38aae08cc5f8db093280259b (diff)
gnu: Add r-tfautograph.
* gnu/packages/cran.scm (r-tfautograph): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8c19d3db1d..c8abaa10d4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30245,6 +30245,29 @@ functions to retrieve the directory of the latest run or latest several
runs.")
(license license:asl2.0)))
+(define-public r-tfautograph
+ (package
+ (name "r-tfautograph")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tfautograph" version))
+ (sha256
+ (base32
+ "1fgpvv330g61ghzhkwnzx04gd9l3d6x1vxd1xqslb05h5acagwqn"))))
+ (properties `((upstream-name . "tfautograph")))
+ (build-system r-build-system)
+ (inputs `(("tensorflow" ,tensorflow)))
+ (propagated-inputs
+ `(("r-reticulate" ,r-reticulate)))
+ (home-page "https://t-kalinowski.github.io/tfautograph/")
+ (synopsis "Autograph R for Tensorflow")
+ (description
+ "This package lets you translate R control flow expressions into
+Tensorflow graphs.")
+ (license license:gpl3)))
+
(define-public r-tensorflow
(package
(name "r-tensorflow")