summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-28 00:21:22 +0200
committerMarius Bakke <marius@gnu.org>2022-07-06 00:35:16 +0200
commitdc5fc7d23f0a4b62f8542bb24abb7ac1b589168d (patch)
treea88171b3a1c768f22a30b316d21775fec80d980a
parent2a023a7bd8acf09480ed934dcdf38e0e23a8c601 (diff)
gnu: pango: Update to 1.50.7.
* gnu/packages/gtk.scm (pango): Update to 1.50.7. (pango-next): Remove variable. (gtk, pangomm)[inputs]: Change from PANGO-NEXT to PANGO.
-rw-r--r--gnu/packages/gtk.scm24
1 files changed, 4 insertions, 20 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ae3b5a91e5..d8ddeff07f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -345,7 +345,7 @@ applications.")
(define-public pango
(package
(name "pango")
- (version "1.48.10")
+ (version "1.50.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/pango/"
@@ -354,7 +354,7 @@ applications.")
(patches (search-patches "pango-skip-libthai-test.patch"))
(sha256
(base32
- "166wxhsjb6hb0dk7wkkdcmpvasl9n0a0aa64mdgagzfdidwzbq91"))))
+ "0cxdwfvr0rsw82nfqzp29mznlx84q2fri9lrfbgrbinlldlz6xq4"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
@@ -399,22 +399,6 @@ handling for GTK+-2.x.")
(home-page "https://pango.gnome.org/")
(license license:lgpl2.0+)))
-;; TODO: Make this the default package in next release cycle.
-(define-public pango-next
- (package
- (inherit pango)
- (name "pango")
- (version "1.50.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/pango/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (patches (search-patches "pango-skip-libthai-test.patch"))
- (sha256
- (base32
- "0qn1a7ccs3p5vc6swbqm6hdzka879l0gp9220lq4bcf2gpl67bgl"))))))
-
(define-public pango-1.42
(package
(inherit pango)
@@ -1234,7 +1218,7 @@ application suites.")
("libxkbcommon" ,libxkbcommon)
("libxrandr" ,libxrandr)
("libxrender" ,libxrender)
- ("pango" ,pango-next)
+ ("pango" ,pango)
("vulkan-headers" ,vulkan-headers)
("vulkan-loader" ,vulkan-loader) ;for vulkan graphics API support
("wayland" ,wayland) ;for wayland display-backend
@@ -1651,7 +1635,7 @@ library.")
("python" ,python)
("xsltproc" ,libxslt)))
(propagated-inputs
- (list cairo cairomm glibmm pango-next))
+ (list cairo cairomm glibmm pango))
(home-page "https://pango.gnome.org//")
(synopsis "C++ interface to the Pango text rendering library")
(description