summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 15:31:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:07 +0200
commite761f0a4756b8a8f58e0ac36345be9fb868ab05d (patch)
tree1ea29fd55d069dc07d6ce1dadc400b5ce7245171
parente0e198fb7013ebfc145e2b66d543549e096d1f4f (diff)
gnu: texlive-etoolbox: Refresh package definition.
* gnu/packages/tex.scm (texlive-etoolbox): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-ETEX.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2283f775ca..76a4256e2a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6182,24 +6182,28 @@ hyperlink to the target of the DOI.")
(define-public texlive-etoolbox
(package
- (inherit (simple-texlive-package
- "texlive-etoolbox"
- (list "/doc/latex/etoolbox/"
- "/tex/latex/etoolbox/")
- (base32
- "070iaj540rglf0c80l0hjkwg6aa7qyskhh4iwyhf7n8vrg5cjjab")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/etoolbox")
+ (name "texlive-etoolbox")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/etoolbox/" "tex/latex/etoolbox/")
+ (base32
+ "070iaj540rglf0c80l0hjkwg6aa7qyskhh4iwyhf7n8vrg5cjjab")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etex))
+ (home-page "https://ctan.org/pkg/etoolbox")
(synopsis "e-TeX tools for LaTeX")
(description
- "This package is a toolbox of programming facilities geared primarily
+ "The package is a toolbox of programming facilities geared primarily
towards LaTeX class and package authors. It provides LaTeX frontends to some
of the new primitives provided by e-TeX as well as some generic tools which
are not strictly related to e-TeX but match the profile of this package. The
package provides functions that seem to offer alternative ways of implementing
some LaTeX kernel commands; nevertheless, the package will not modify any part
of the LaTeX kernel.")
- (license license:lppl1.3+)))
+ (license license:lppl1.3c+)))
(define-deprecated-package texlive-latex-etoolbox texlive-etoolbox)