summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-01-30 16:25:10 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:51 +0200
commite8745331da42aea3f53946fc222c5aa84111a231 (patch)
tree29cd67a7bcad046b458e5bfb5134ae18536313ea
parent84bfdd13df051ac211c59ae897e2757967ffbb4b (diff)
gnu: Add rust-event-listener-4.
* gnu/packages/crates-io.scm (rust-event-listener-4): Add variable. (rust-event-listener-2): Inherit from rust-event-listener-4. Change-Id: I23ebc60b21fb33e992832553dd9817672b4fb920 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm39
1 files changed, 32 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b0429d9e91..f4155f26f8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21939,23 +21939,31 @@ they follow. Etcetera, on the other hand, gives you the choice.")
(description "This package provides evdev interface for Linux.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-event-listener-2
+(define-public rust-event-listener-4
(package
(name "rust-event-listener")
- (version "2.5.3")
+ (version "4.0.3")
(source
(origin
(method url-fetch)
(uri (crate-uri "event-listener" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1q4w3pndc518crld6zsqvvpy9lkzwahp2zgza9kbzmmqh9gif1h2"))))
+ (base32 "0vk4smw1vf871vi76af1zn7w69jg3zmpjddpby2qq91bkg21bck7"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-development-inputs
- (("rust-futures" ,rust-futures-0.3)
- ("rust-waker-fn" ,rust-waker-fn-1))))
- (home-page "https://github.com/stjepang/event-listener")
+ `(#:cargo-inputs
+ (("rust-concurrent-queue" ,rust-concurrent-queue-2)
+ ("rust-parking" ,rust-parking-2)
+ ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
+ ("rust-portable-atomic" ,rust-portable-atomic-1)
+ ("rust-portable-atomic-util" ,rust-portable-atomic-util-0.1))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.5)
+ ("rust-futures-lite" ,rust-futures-lite-2)
+ ("rust-waker-fn" ,rust-waker-fn-1)
+ ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3))))
+ (home-page "https://github.com/smol-rs/event-listener")
(synopsis "Notify async tasks or threads")
(description
"This is a synchronization primitive similar to @code{eventcounts}.
@@ -21963,6 +21971,23 @@ You can use this crate to turn non-blocking data structures into async or
blocking data structures.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-event-listener-2
+ (package
+ (inherit rust-event-listener-4)
+ (name "rust-event-listener")
+ (version "2.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "event-listener" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1q4w3pndc518crld6zsqvvpy9lkzwahp2zgza9kbzmmqh9gif1h2"))))
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-futures" ,rust-futures-0.3)
+ ("rust-waker-fn" ,rust-waker-fn-1))))))
+
(define-public rust-executable-path-1
(package
(name "rust-executable-path")