summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:20:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:35 +0200
commiteb44c8892379c35947184fbe48275e0c3169828c (patch)
treee5f2785d1636e66e3115b294da30895cb71e24e6
parent87142f0a9bd130ea683611b03a8c686e40bb6964 (diff)
gnu: texlive-babel-polish: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-babel-polish!): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2718c71b9f..3914808692 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13061,26 +13061,25 @@ settings to typeset Danish documents.")
(license license:lppl1.3c+)))
(define-public texlive-babel-polish
- (let ((template (simple-texlive-package
- "texlive-babel-polish"
- (list "/source/generic/babel-polish/")
- (base32
- "1jymxl98mwxmq0yq90mhrr7bq7c613rh1rnhl7l3bih36af55rwr"))))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "generic/babel-polish")
- ((#:build-targets _ '())
- ''("polish.ins"))))
- (home-page "https://www.ctan.org/pkg/babel-polish")
- (synopsis "Babel support for Polish")
- (description
- "This package provides the language definition file for support of
-Polish in @code{babel}. Some shortcuts are defined, as well as translations to
-Polish of standard ``LaTeX names''.")
- (license license:lppl1.3+))))
+ (package
+ (name "texlive-babel-polish")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/babel-polish/"
+ "source/generic/babel-polish/"
+ "tex/generic/babel-polish/")
+ (base32
+ "0an9csjd4jhz6civdldsrmz7l76hw8zfcgxdp55mj8f1rchsjylx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/babel-polish")
+ (synopsis "Babel support for Polish")
+ (description
+ "This package provides the language definition file for support of Polish
+in @code{babel}. Some shortcuts are defined, as well as translations to
+Polish of standard LaTeX names.")
+ (license license:lppl1.3+)))
(define-public texlive-mdframed
(package