summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 22:53:24 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:11 +0200
commitef46db38a9527e9bd4b7489d5bed41cf10820955 (patch)
tree0c395b45d8fc63dc38234b7af19b430a97d091ba
parent3e240e15e54ad613faedb4f27f689f2a7054d29e (diff)
gnu: Add rust-grep-matcher-0.1.
* gnu/packages/crates-io.scm (rust-grep-matcher-0.1): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a2c40fc787..6187a57763 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1331,6 +1331,34 @@ path simultaneously, and returning all of the globs that matched.")
"Utilities for search oriented command line applications.")
(license license:expat)))
+(define-public rust-grep-matcher-0.1
+ (package
+ (name "rust-grep-matcher")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "grep-matcher" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03j26zygfgwyam66bl5g922gimrvp4yyzl8qvaykyklnf247bl3r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-memchr" ,rust-memchr-2.2))
+ #:cargo-development-inputs
+ (("rust-regex" ,rust-regex-1.1))))
+ (home-page "https://github.com/BurntSushi/ripgrep")
+ (synopsis "Trait for regular expressions")
+ (description
+ "This crate provides a low level interface for describing regular
+expression matchers. The @code{grep} crate uses this interface in order to make
+the regex engine it uses pluggable.")
+ (license (list license:expat license:unlicense))))
+
(define-public rust-grep-pcre2-0.1
(package
(name "rust-grep-pcre2")