summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:14:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:33:17 +0200
commitf2943958a224beda05a3d040876df2a7285cd7a2 (patch)
tree7688a067b554e9742c56b641747c3d59fd18bd85
parent2b707a150c86642ccd7d2c428ffe58d328069e43 (diff)
gnu: Add texlive-collection-langother.
* gnu/packages/tex.scm (texlive-collection-langother): New variable.
-rw-r--r--gnu/packages/tex.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e33b8676ea..4c864b7b56 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -39748,6 +39748,73 @@ simply on the size of the support.")
(description "This collection provides support packages for Italian.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-langother
+ (package
+ (name "texlive-collection-langother")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-aalok
+ texlive-akshar
+ texlive-amsldoc-vn
+ texlive-aramaic-serto
+ texlive-babel-azerbaijani
+ texlive-babel-esperanto
+ texlive-babel-georgian
+ texlive-babel-hebrew
+ texlive-babel-indonesian
+ texlive-babel-interlingua
+ texlive-babel-malay
+ texlive-babel-sorbian
+ texlive-babel-thai
+ texlive-babel-vietnamese
+ texlive-bangla
+ texlive-bangtex
+ texlive-bengali
+ texlive-burmese
+ texlive-chhaya
+ texlive-cjhebrew
+ texlive-collection-basic
+ texlive-ctib
+ texlive-ebong
+ texlive-ethiop
+ texlive-ethiop-t1
+ texlive-fc
+ texlive-fonts-tlwg
+ texlive-hindawi-latex-template
+ texlive-hyphen-complete
+ texlive-latex-mr
+ texlive-latexbangla
+ texlive-latino-sine-flexione
+ texlive-lshort-thai
+ texlive-lshort-vietnamese
+ texlive-marathi
+ texlive-ntheorem-vn
+ texlive-padauk
+ texlive-quran-bn
+ texlive-quran-ur
+ texlive-sanskrit
+ texlive-sanskrit-t1
+ texlive-thaienum
+ texlive-thaispec
+ texlive-unicode-alphabets
+ texlive-velthuis
+ texlive-vntex
+ texlive-wnri
+ texlive-wnri-latex
+ texlive-xetex-devanagari))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Support other languages")
+ (description
+ "This collection provides support for languages not otherwise listed,
+including Indic, Thai, Vietnamese, Hebrew, Indonesian, African languages, and
+plenty more. The split is made simply on the basis of the size of the
+support, to keep both collection sizes and the number of collections
+reasonable.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-collection-langpolish
(package
(name "texlive-collection-langpolish")