summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:46:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:54 +0200
commitf35acb911be34e54564a2ca17a173bf832afb1a7 (patch)
treee8cc8b3d0a52c2186647739c0f619b3fb314ed06
parent92f820efca7d83248dc20cb1b827d2fb878ebee0 (diff)
gnu: texlive-infwarerr: Refresh package definition.
* gnu/packages/tex.scm (texlive-infwarerr): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 20 insertions, 24 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c74377140c..74dafc6bea 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9618,30 +9618,26 @@ strings.")
(define-deprecated-package texlive-generic-gettitlestring texlive-gettitlestring)
(define-public texlive-infwarerr
- (let ((template (simple-texlive-package
- "texlive-infwarerr"
- (list "doc/latex/infwarerr/"
- "source/latex/infwarerr/"
- "tex/generic/infwarerr/")
- (base32
- "0lpcrpf3d6xfdp68ri22126x57mvmq5dpj9np68ph8p8lhvhqdjd"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "generic/infwarerr")
- ((#:build-targets _ '())
- #~(list "infwarerr.dtx"))))
- (home-page "https://www.ctan.org/pkg/infwarerr")
- (synopsis "Information/warning/error macros")
- (description
- "This package provides a complete set of macros for information,
-warning and error messages. Under LaTeX, the commands are wrappers for
-the corresponding LaTeX commands; under Plain TeX they are available as
-complete implementations.")
- (license license:lppl1.3c+))))
+ (package
+ (name "texlive-infwarerr")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/infwarerr/"
+ "source/latex/infwarerr/"
+ "tex/generic/infwarerr/")
+ (base32
+ "0lpcrpf3d6xfdp68ri22126x57mvmq5dpj9np68ph8p8lhvhqdjd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/infwarerr")
+ (synopsis "Complete set of information/warning/error message macros")
+ (description
+ "This package provides a complete set of macros for information, warning
+and error messages. Under LaTeX, the commands are wrappers for the
+corresponding LaTeX commands; under Plain TeX they are available as complete
+implementations.")
+ (license license:lppl1.3+)))
(define-deprecated-package texlive-generic-infwarerr texlive-infwarerr)