summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:44:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:29 +0200
commitf7885d984ee526be877cdac89ff94630384cbd90 (patch)
tree534d53746c47b477d468b3dcd27880b3c9ccbb61
parent80035f022205135902261c2988701bcd51146b0a (diff)
gnu: Add texlive-newpx.
* gnu/packages/tex.scm (texlive-newpx): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fc2257c228..e79cfb54ca 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19516,6 +19516,34 @@ Mathematics, all compatible in style to CM fonts. In addition to the Regular
weight of Computer Modern, it provides a Book weight for heavier printing.")
(license license:gfl1.0)))
+(define-public texlive-newpx
+ (package
+ (name "texlive-newpx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/newpx/"
+ "fonts/afm/public/newpx/"
+ "fonts/enc/dvips/newpx/"
+ "fonts/map/dvips/newpx/"
+ "fonts/opentype/public/newpx/"
+ "fonts/tfm/public/newpx/"
+ "fonts/type1/public/newpx/"
+ "fonts/vf/public/newpx/"
+ "tex/latex/newpx/")
+ (base32
+ "1c58073pzqa9sl69rfqy8b4j8i3fy3hil57fh51icvr5ggq5vyfn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/newpx")
+ (synopsis "Alternative uses of the PX fonts, with improved metrics")
+ (description
+ "This package, initially based on @code{pxfonts}, provides many fixes and
+enhancements to that package, and splits it in two parts (@code{newpxtext} and
+@code{newpxmath}) which may be run independently of one another. It provides
+scaling, improved metrics, and other options.")
+ (license (list license:lppl license:silofl1.1))))
+
(define-public texlive-nicematrix
(package
(name "texlive-nicematrix")