summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:17 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:09:38 +0100
commitf883cb9ecd6ca14bf89aad4d2eb0e52809d8bd23 (patch)
treea5653033f1b3223273e1dec1d859fcdb843b5b92
parent8160d05e83d8b9284d3c6b18218cf639db90141b (diff)
gnu: Add ocaml-bechamel.
* gnu/packages/ocaml.scm (ocaml-bechamel): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9040748fce..7e54245865 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3610,6 +3610,30 @@ your functions and to easily compare the results. A statistical test
is used to determine whether the results truly differ.")
(license license:lgpl3+)))
+(define-public ocaml-bechamel
+ (package
+ (name "ocaml-bechamel")
+ (version "0.3.0")
+ (home-page "https://github.com/mirage/bechamel")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x7sf45iy5dzx7kknbkkvpna42rcwpj5p55y0nqsg2fb4srj0b1q"))))
+ (build-system dune-build-system)
+ (arguments `(#:package "bechamel"))
+ (propagated-inputs (list ocaml-fmt ocaml-stdlib-shims))
+ (synopsis "Yet Another Benchmark in OCaml")
+ (description
+ "BEnchmark for a CHAMEL/camel/caml which is agnostic to the system. It's a
+micro-benchmark tool for OCaml which lets the user to re-analyzes and prints
+samples.")
+ (license license:expat)))
+
(define-public ocaml-batteries
(package
(name "ocaml-batteries")