summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:50:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:36 +0200
commitfbd8ced0afc129278aa5cf89ea6ff7f859f3a8a7 (patch)
tree058be690bb55979eb6402c2fd233f5931c388950
parentc79c0f3fc120c99f99e5d2881e1873352847866b (diff)
gnu: Add texlive-paratype.
* gnu/packages/tex.scm (texlive-paratype): New variable.
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc4cab7cc4..4587999545 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -20742,6 +20742,46 @@ arrangement of text is commonly used when typesetting translations, but it can
have value when comparing any two texts.")
(license license:lppl)))
+(define-public texlive-paratype
+ (package
+ (name "texlive-paratype")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/paratype/"
+ "fonts/afm/paratype/ptmono/"
+ "fonts/afm/paratype/ptsans/"
+ "fonts/afm/paratype/ptserif/"
+ "fonts/enc/dvips/paratype/"
+ "fonts/map/dvips/paratype/"
+ "fonts/tfm/paratype/ptmono/"
+ "fonts/tfm/paratype/ptsans/"
+ "fonts/tfm/paratype/ptserif/"
+ "fonts/truetype/paratype/ptmono/"
+ "fonts/truetype/paratype/ptsans/"
+ "fonts/truetype/paratype/ptserif/"
+ "fonts/type1/paratype/ptmono/"
+ "fonts/type1/paratype/ptsans/"
+ "fonts/type1/paratype/ptserif/"
+ "fonts/vf/paratype/ptmono/"
+ "fonts/vf/paratype/ptsans/"
+ "fonts/vf/paratype/ptserif/"
+ "tex/latex/paratype/")
+ (base32
+ "0k93y4xlng9b9cwa9mk7bdxj2zzbyigv02z358lm0vpr7nw8vxig")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/paratype")
+ (synopsis "LaTeX support for ParaType fonts")
+ (description
+ "The package offers LaTeX support for the fonts PT Sans, PT Serif and PT
+Mono developed by ParaType for the project @emph{Public Types of Russian
+Federation}. The fonts themselves are provided in both the TrueType and Type
+1 formats. The fonts provide encodings OT1, T1, IL2, TS1, T2* and X2. The
+package provides a convenient replacement of the two packages @code{ptsans}
+and @code{ptserif}.")
+ (license license:lppl)))
+
(define-public texlive-parrun
(package
(name "texlive-parrun")